Eclipse als Mediawiki Editor

Aus Physik
Version vom 27. Februar 2005, 18:37 Uhr von Camhy (Diskussion | Beiträge)
(Unterschied) ← Nächstältere Version | Aktuelle Version (Unterschied) | Nächstjüngere Version → (Unterschied)
Zur Navigation springen Zur Suche springen

NOCH NICHT FERTIG

Globale Wiki Einstellungen

Bevor Sie mit dem Erstellen eines neuen Mediawiki Projektes beginnen, müssen Sie einige globale Einstellungen vornehmen, damit sie auf die Mediawiki-Seiten des Instituts zugreifen können:

  • Öffnen Sie die Benutzervorgaben durch Fenster->Benutzervorgaben. Wechseln Sie im linken Baum auf

Wikipedia Editor Configurations

http://www.itp.tugraz.at/Comp/Eclipse/screenshots/eclipse_mediawiki_6.jpg

  • Anschließend sehen Sie auf der rechten Seite alle vordefinierten Mediawiki-Einstellungen. Sollte

das ITP Wiki noch nicht vorkonfiguriert sein, fügen Sie durch Klicken auf Add.. eine neue Konfiguration hinzu:

http://www.itp.tugraz.at/Comp/Eclipse/screenshots/eclipse_mediawiki_7.jpg

Tragen Sie die URL http://faeppc14.tu-graz.ac.at/wiki/index.php/Special:Export als ITP Download HTTP Action in den Dialog ein (natürlich mit Ihrem Mediawiki-Benutzernamen und Passwort):

http://www.itp.tugraz.at/Comp/Eclipse/screenshots/eclipse_mediawiki_8.jpg

Anschließend klicken sie noch einmal auf Add.. und definieren eine HTTP Upload Action mit http://faeppc14.tu-graz.ac.at/wiki/index.php:

http://www.itp.tugraz.at/Comp/Eclipse/screenshots/eclipse_mediawiki_9.jpg

Erstellen eines Mediawiki-Projekts

  • Wechseln Sie in die Mediawiki - Perspektive (dies ist eine Benutzerdefinierte Perspektive, die nur am Institut oder zu Hause mit der Eclipse ITP Edition zur Verfügung steht), durch Fenster->Perspektive Öffnen-> Andere....

Falls Sie diese Perspektive nicht benutzen wollen oder können, benutzen Sie eine beliebige andere vordefinierte Perspektive.

http://www.itp.tugraz.at/Comp/Eclipse/screenshots/eclipse_mediawiki_2.jpg http://www.itp.tugraz.at/Comp/Eclipse/screenshots/eclipse_mediawiki_1.jpg http://www.itp.tugraz.at/Comp/Eclipse/screenshots/eclipse_mediawiki_3.jpg


  • Generieren Sie ein neues Wikipedia-Projekt durch Datei->Neu->Projekt->Wikipedia->Wikipedia Project..

http://www.itp.tugraz.at/Comp/Eclipse/screenshots/eclipse_mediawiki_4.jpg

Vergeben Sie einen Projektnamen:

http://www.itp.tugraz.at/Comp/Eclipse/screenshots/eclipse_mediawiki_5.jpg