MLTutor: Unterschied zwischen den Versionen

Aus Physik
Zur Navigation springen Zur Suche springen
 
(19 dazwischenliegende Versionen von 4 Benutzern werden nicht angezeigt)
Zeile 1: Zeile 1:
  +
Diese Seite ist nicht für Studierende gedacht. Sie dient zur Information für die Lehrveranstaltungsbetreuer.
== Übungsblätter ==
 
   
  +
== Aktuelles ==
Startet den Browser durch Klick auf das Desktopicon Firefox / Browser.
 
  +
=== Auschecken der Beispiele für 2008 ===
  +
* In die MLTutor-Admin-Ansicht wechseln.
  +
* Rechtsklick auf einen "Exercise..."-Folder
  +
** Create Project Set
  +
* Jetzt sollte in der Matlab Workbench unter mltutor_projectsets eine Datei
  +
kernbich.exercisecollections.2008.*.psf existieren.
  +
* Rechtsklick auf diese Datei -> Arbeitsset erstellen (Namen für den Arbeitsset wählen)
  +
* Nochmals Rechtsklick und "Laden/Ersetzen" anklicken. Jetzt werden die Beispiele geholt.
  +
* Der Workingset kann über das Menü unter dem kleinen weißen Pfeil rechts oberhalb der Baumstruktur ausgewählt werden.
   
  +
=== Folgende Punkte in den alten Projekten ausbessern ===
Die Übungsblätter findet ihr unter:
 
  +
* Sollten noch Testskripte existieren, die z. B. ml_test1_before, test3_after o.ä. heißen, diesen bitte einen aussagekräftigen Namen geben. Z.B.
http://itp.tugraz.at/wiki/index.php/Applikationssoftware_und_Programmierung
 
  +
** graphics_request.m, wenn Graphikattribute angefragt werden. disp_request.m, empty.m oder nothing_to_do.m ...
  +
* Überprüfungen von Textausgaben via MLTutor_ERROR_REQUEST.message, MLTutor_ERROR_REQUEST.type und auch DISP_REQUEST.message, DISP_REQUEST.type durch Tests mit Regular Expressions ersetzen [[MLTutorBeispielerstellung#Überprüfung_von_Textausgaben]].
  +
Eine Liste der Dateien, in denen ich auf die Schnelle sowas gefunden habe, befindet sich auf meiner Seite [[User:Schrodk]].
   
  +
'''Noch aus dem Jahr 07, aber darauf auch nochmal achten'''
TIP: Im Firefox könnt ihr mehrere Tabs gleichzeitig öffnen: Rechtsklick auf Link -> Open Link in new Tab
 
  +
*In den Before und After Sripts für Studenten sehbare Bereiche mit %### einrahmen
== MLTutor Bedienung ==
 
  +
* Sollte das Beispiel Datenfiles benötigen, diese im .mlt-File unter '''Extra Dateien''' eintragen und die Angabe ausbessern. Datenfiles müssen ins Projektverzeichnis kopiert werden.
  +
*Rechtschreibfehler
  +
*Tests überprüfen und ergänzen, so dass die Studenten verstehen was, wie und warum getestet wird.
   
  +
== Einstellen von Beispielen in den MLTutor ==
=== Starten des Programms ===
 
  +
=== Matlab - Files ===
  +
==== Erstmaliges einstellen ====
  +
# In die Admin-Perspective wechseln
  +
# Im rechten unteren Fenster das Tab 'Example Admin' auswählen
  +
# rechts oben zweites Icon von links (Add Example) auswählen
  +
# Category -> wählen Welche Übung
  +
# Wenn das Beispiel drinnen ist läßt sich durch Doppelklick ein Fenster öffnen in dem man z.B. die visibility (Reihenfolge) ändern kann.
  +
# Unter rights läßt sich einstellen, ob das Beispiel sichtbar sein soll oder nicht. Wird bei Prüfungsbeispielen automatisch auf 'not visible' gesetzt.
   
  +
==== Update ====
Startet das Programm durch Doppelklick auf das Matlab-Tutor Desktop Icon.
 
  +
Im Example Admin Rechtsklick auf jeweiliges Beispiel und 'Update Example from Workspace' auswählen.
Nach dem Start seht ihr ein Login-Fenster, bei dem ihr euch mit dem Benutzernamen und Passwort,
 
dass ihr auch zum Login in das System verwendet, anmeldet.
 
Wenn ihr euch das erste Mal anmeldet, werden einige persönliche Daten erfragt.
 
Bitte tragt bei Namen nur euren Nachnamen ein. Das Vornamenfeld kommt noch..
 
   
  +
==== Exercise Collections ====
Diese Daten könnt ihr auch im Nachhinein immer ändern, indem ihr das entsprechende Toolbaricon im MLTutor auswählt (Bitte Tooltip beachten)
 
  +
... werden mit dem grünen Knopf rechts oben im Example Admin hinzugefügt. Auch bei ihnen lassen sich mit Doppelklick anschließend gewisse Eigenschaften (z.B. Sichtbarkeit) einstellen.
   
=== Ein erstes Projekt ===
+
=== Angaben ===
  +
Hier genügt es in der 'Matlab Workbench' Perspektive einen Rechtsklick auf das pdf-File auszuführen und im Menü 'Update PDF File for MLTutor' auszuwählen.
   
  +
== Erstellen von Beispielen ==
Erstellt ein erstes Matlab Projekt entweder durch
 
  +
Hinweise zur Erstellung eines Beispiels (und der Tests) sind auf der Seite [[MLTutorBeispielerstellung]] zu finden.
File->New->Matlab Project
 
oder durch
 
Kontextmenü (rechter Mausklick) im Matlab Projects View > New > Matlab Project
 
   
  +
[[Category:MLTutor]]
Bitte gebt diesem Projekt den Namen: Uebung_1
 
 
=== Erstellen eines Matlab Files ===
 
 
In diesem Matlab Projekt könnt ihr nun ein neues Matlab File erstellen.
 
Entweder:
 
File->New->Matlab File->Oben Auswahl auf Uebung 1 setzen->File name: basis1.m
 
oder das gleiche wieder über das Kontextmenü im "Matlab Projects View"
 
 
=== Problem View ===
 
 
Wenn ihr ein Matlab File bearbeitet, wird jeweils nach dem Speichern eine Syntaxüberprüfung durchgeführt.
 
Etwaige Probleme seht ihr rechts unten im "Problems View". Durch Klick auf das jeweilige Problem springt ihr zur Zeile, in der das Problem auftaucht.
 
 
=== Zeilennummern ===
 
 
Ihr könnt die Zeilennummern im Matlab Editor durch
 
 
Window->Preferences->Matlab Editor->Show Line Numbers
 
 
einschalten
 
 
=== Matlab Console ===
 
 
In der Matlab Konsole könnt ihr Matlab Befehle eingeben, die mit RETURN ausgeführt werden.
 
 
TIP: Durch Pfeil rauf und runter könnt ihr in der Command History vor und zurückblättern.
 
 
=== Matlab Workspace View ===
 
 
Ihr könnt die Variablen, die in eurem Workspace zur Verfügung stehen im Matlab Workspace View unterteilt in globale und lokale Variablen betrachten
 
 
=== Ausführen eines Matlab Skripts ===
 
 
Ein Matlab Skript könnt ihr entweder durch:
 
 
Kontextmenü (rechter Mausklick) auf Datei -> Run Matlab Skript
 
 
oder über das entsprechende Icon in der Toolbar ausführen.
 
 
TIP: Um das Ergebnis bzw. veränderte Variablen zu sehen wechselt bitte in den "Matlab Workspace View"
 

Aktuelle Version vom 23. Oktober 2007, 21:26 Uhr

Diese Seite ist nicht für Studierende gedacht. Sie dient zur Information für die Lehrveranstaltungsbetreuer.

Aktuelles

Auschecken der Beispiele für 2008

  • In die MLTutor-Admin-Ansicht wechseln.
  • Rechtsklick auf einen "Exercise..."-Folder
    • Create Project Set
  • Jetzt sollte in der Matlab Workbench unter mltutor_projectsets eine Datei

kernbich.exercisecollections.2008.*.psf existieren.

  • Rechtsklick auf diese Datei -> Arbeitsset erstellen (Namen für den Arbeitsset wählen)
  • Nochmals Rechtsklick und "Laden/Ersetzen" anklicken. Jetzt werden die Beispiele geholt.
  • Der Workingset kann über das Menü unter dem kleinen weißen Pfeil rechts oberhalb der Baumstruktur ausgewählt werden.

Folgende Punkte in den alten Projekten ausbessern

  • Sollten noch Testskripte existieren, die z. B. ml_test1_before, test3_after o.ä. heißen, diesen bitte einen aussagekräftigen Namen geben. Z.B.
    • graphics_request.m, wenn Graphikattribute angefragt werden. disp_request.m, empty.m oder nothing_to_do.m ...
  • Überprüfungen von Textausgaben via MLTutor_ERROR_REQUEST.message, MLTutor_ERROR_REQUEST.type und auch DISP_REQUEST.message, DISP_REQUEST.type durch Tests mit Regular Expressions ersetzen MLTutorBeispielerstellung#Überprüfung_von_Textausgaben.

Eine Liste der Dateien, in denen ich auf die Schnelle sowas gefunden habe, befindet sich auf meiner Seite User:Schrodk.

Noch aus dem Jahr 07, aber darauf auch nochmal achten

  • In den Before und After Sripts für Studenten sehbare Bereiche mit %### einrahmen
  • Sollte das Beispiel Datenfiles benötigen, diese im .mlt-File unter Extra Dateien eintragen und die Angabe ausbessern. Datenfiles müssen ins Projektverzeichnis kopiert werden.
  • Rechtschreibfehler
  • Tests überprüfen und ergänzen, so dass die Studenten verstehen was, wie und warum getestet wird.

Einstellen von Beispielen in den MLTutor

Matlab - Files

Erstmaliges einstellen

  1. In die Admin-Perspective wechseln
  2. Im rechten unteren Fenster das Tab 'Example Admin' auswählen
  3. rechts oben zweites Icon von links (Add Example) auswählen
  4. Category -> wählen Welche Übung
  5. Wenn das Beispiel drinnen ist läßt sich durch Doppelklick ein Fenster öffnen in dem man z.B. die visibility (Reihenfolge) ändern kann.
  6. Unter rights läßt sich einstellen, ob das Beispiel sichtbar sein soll oder nicht. Wird bei Prüfungsbeispielen automatisch auf 'not visible' gesetzt.

Update

Im Example Admin Rechtsklick auf jeweiliges Beispiel und 'Update Example from Workspace' auswählen.

Exercise Collections

... werden mit dem grünen Knopf rechts oben im Example Admin hinzugefügt. Auch bei ihnen lassen sich mit Doppelklick anschließend gewisse Eigenschaften (z.B. Sichtbarkeit) einstellen.

Angaben

Hier genügt es in der 'Matlab Workbench' Perspektive einen Rechtsklick auf das pdf-File auszuführen und im Menü 'Update PDF File for MLTutor' auszuwählen.

Erstellen von Beispielen

Hinweise zur Erstellung eines Beispiels (und der Tests) sind auf der Seite MLTutorBeispielerstellung zu finden.