MLTutor: Unterschied zwischen den Versionen

Aus Physik
Zur Navigation springen Zur Suche springen
 
(12 dazwischenliegende Versionen von 3 Benutzern werden nicht angezeigt)
Zeile 1: Zeile 1:
 
Diese Seite ist nicht für Studierende gedacht. Sie dient zur Information für die Lehrveranstaltungsbetreuer.
 
Diese Seite ist nicht für Studierende gedacht. Sie dient zur Information für die Lehrveranstaltungsbetreuer.
* [[Liste der Exercises]]
 
   
  +
== Aktuelles ==
== Umbenenung eines MLTutor Beispiels für das Jahr 2007 ==
 
  +
=== Auschecken der Beispiele für 2008 ===
* Checkout des Alten Projekts
 
  +
* In die MLTutor-Admin-Ansicht wechseln.
(z.B: andrej.2006.matrix und andrej.2006.matrix.de)
 
  +
* Rechtsklick auf einen "Exercise..."-Folder
* Disconnecten von dem CVS, auch die CVS Metainformationen Löschen lassen
 
  +
** Create Project Set
* Umbennen des Projektverzeichnisses mit folgender Konvention 2007.appsoft.beispielname bzw. 2007.appsoft.beispielname.de
 
  +
* Jetzt sollte in der Matlab Workbench unter mltutor_projectsets eine Datei
* im mlt- file im Tab runtime -> Latex-Project -> Standard
 
  +
kernbich.exercisecollections.2008.*.psf existieren.
* vor dem CVS checkin folgende Optionen anpassen:
 
  +
* Rechtsklick auf diese Datei -> Arbeitsset erstellen (Namen für den Arbeitsset wählen)
** window -> Preferences -> Team -> Ignored resources folgendes ergänzen: *.out, *.log, *.aux,
 
  +
* Nochmals Rechtsklick und "Laden/Ersetzen" anklicken. Jetzt werden die Beispiele geholt.
** window -> Preferences -> Team -> File Content: *.tex, *.m, *.mlt und sonstige Text-Files auf ASCII text umstellen
 
  +
* Der Workingset kann über das Menü unter dem kleinen weißen Pfeil rechts oberhalb der Baumstruktur ausgewählt werden.
* dann Checkin mit Rechtsklick auf Projektverzeichniss->Team->share Project oder so
 
   
== Folgende Punkte in den alten Projekten ausbessern ==
+
=== Folgende Punkte in den alten Projekten ausbessern ===
  +
* Sollten noch Testskripte existieren, die z. B. ml_test1_before, test3_after o.ä. heißen, diesen bitte einen aussagekräftigen Namen geben. Z.B.
*Verzeichnissnamen: 2007.appsoft.beispielname bzw. 2007.appsoft.beispielname.de
 
  +
** graphics_request.m, wenn Graphikattribute angefragt werden. disp_request.m, empty.m oder nothing_to_do.m ...
  +
* Überprüfungen von Textausgaben via MLTutor_ERROR_REQUEST.message, MLTutor_ERROR_REQUEST.type und auch DISP_REQUEST.message, DISP_REQUEST.type durch Tests mit Regular Expressions ersetzen [[MLTutorBeispielerstellung#Überprüfung_von_Textausgaben]].
  +
Eine Liste der Dateien, in denen ich auf die Schnelle sowas gefunden habe, befindet sich auf meiner Seite [[User:Schrodk]].
  +
  +
'''Noch aus dem Jahr 07, aber darauf auch nochmal achten'''
 
*In den Before und After Sripts für Studenten sehbare Bereiche mit %### einrahmen
 
*In den Before und After Sripts für Studenten sehbare Bereiche mit %### einrahmen
* Sollte das Beispiel Datenfiles benötigen, diese im .mlt-File unter '''Extra Dateien''' eintragen, und die Angabe ausbessern. Datenfiles müssen ins Projektverzeichnis kopiert werden.
+
* Sollte das Beispiel Datenfiles benötigen, diese im .mlt-File unter '''Extra Dateien''' eintragen und die Angabe ausbessern. Datenfiles müssen ins Projektverzeichnis kopiert werden.
 
*Rechtschreibfehler
 
*Rechtschreibfehler
*Tests überprüfen und ergänzen, so dass die Studenten verstehen was, wie und warum getestet wird
+
*Tests überprüfen und ergänzen, so dass die Studenten verstehen was, wie und warum getestet wird.
   
 
== Einstellen von Beispielen in den MLTutor ==
 
== Einstellen von Beispielen in den MLTutor ==
Zeile 41: Zeile 45:
 
== Erstellen von Beispielen ==
 
== Erstellen von Beispielen ==
 
Hinweise zur Erstellung eines Beispiels (und der Tests) sind auf der Seite [[MLTutorBeispielerstellung]] zu finden.
 
Hinweise zur Erstellung eines Beispiels (und der Tests) sind auf der Seite [[MLTutorBeispielerstellung]] zu finden.
  +
  +
[[Category:MLTutor]]

Aktuelle Version vom 23. Oktober 2007, 21:26 Uhr

Diese Seite ist nicht für Studierende gedacht. Sie dient zur Information für die Lehrveranstaltungsbetreuer.

Aktuelles

Auschecken der Beispiele für 2008

  • In die MLTutor-Admin-Ansicht wechseln.
  • Rechtsklick auf einen "Exercise..."-Folder
    • Create Project Set
  • Jetzt sollte in der Matlab Workbench unter mltutor_projectsets eine Datei

kernbich.exercisecollections.2008.*.psf existieren.

  • Rechtsklick auf diese Datei -> Arbeitsset erstellen (Namen für den Arbeitsset wählen)
  • Nochmals Rechtsklick und "Laden/Ersetzen" anklicken. Jetzt werden die Beispiele geholt.
  • Der Workingset kann über das Menü unter dem kleinen weißen Pfeil rechts oberhalb der Baumstruktur ausgewählt werden.

Folgende Punkte in den alten Projekten ausbessern

  • Sollten noch Testskripte existieren, die z. B. ml_test1_before, test3_after o.ä. heißen, diesen bitte einen aussagekräftigen Namen geben. Z.B.
    • graphics_request.m, wenn Graphikattribute angefragt werden. disp_request.m, empty.m oder nothing_to_do.m ...
  • Überprüfungen von Textausgaben via MLTutor_ERROR_REQUEST.message, MLTutor_ERROR_REQUEST.type und auch DISP_REQUEST.message, DISP_REQUEST.type durch Tests mit Regular Expressions ersetzen MLTutorBeispielerstellung#Überprüfung_von_Textausgaben.

Eine Liste der Dateien, in denen ich auf die Schnelle sowas gefunden habe, befindet sich auf meiner Seite User:Schrodk.

Noch aus dem Jahr 07, aber darauf auch nochmal achten

  • In den Before und After Sripts für Studenten sehbare Bereiche mit %### einrahmen
  • Sollte das Beispiel Datenfiles benötigen, diese im .mlt-File unter Extra Dateien eintragen und die Angabe ausbessern. Datenfiles müssen ins Projektverzeichnis kopiert werden.
  • Rechtschreibfehler
  • Tests überprüfen und ergänzen, so dass die Studenten verstehen was, wie und warum getestet wird.

Einstellen von Beispielen in den MLTutor

Matlab - Files

Erstmaliges einstellen

  1. In die Admin-Perspective wechseln
  2. Im rechten unteren Fenster das Tab 'Example Admin' auswählen
  3. rechts oben zweites Icon von links (Add Example) auswählen
  4. Category -> wählen Welche Übung
  5. Wenn das Beispiel drinnen ist läßt sich durch Doppelklick ein Fenster öffnen in dem man z.B. die visibility (Reihenfolge) ändern kann.
  6. Unter rights läßt sich einstellen, ob das Beispiel sichtbar sein soll oder nicht. Wird bei Prüfungsbeispielen automatisch auf 'not visible' gesetzt.

Update

Im Example Admin Rechtsklick auf jeweiliges Beispiel und 'Update Example from Workspace' auswählen.

Exercise Collections

... werden mit dem grünen Knopf rechts oben im Example Admin hinzugefügt. Auch bei ihnen lassen sich mit Doppelklick anschließend gewisse Eigenschaften (z.B. Sichtbarkeit) einstellen.

Angaben

Hier genügt es in der 'Matlab Workbench' Perspektive einen Rechtsklick auf das pdf-File auszuführen und im Menü 'Update PDF File for MLTutor' auszuwählen.

Erstellen von Beispielen

Hinweise zur Erstellung eines Beispiels (und der Tests) sind auf der Seite MLTutorBeispielerstellung zu finden.