MLTutor: Unterschied zwischen den Versionen

Aus Physik
Zur Navigation springen Zur Suche springen
Zeile 6: Zeile 6:
 
http://itp.tugraz.at/wiki/index.php/Applikationssoftware_und_Programmierung
 
http://itp.tugraz.at/wiki/index.php/Applikationssoftware_und_Programmierung
   
  +
TIP: Im Firefox könnt ihr mehrere Tabs
 
== MLTutor Bedienung ==
 
== MLTutor Bedienung ==
   
Zeile 24: Zeile 25:
 
Erstellt ein erstes Matlab Projekt entweder durch
 
Erstellt ein erstes Matlab Projekt entweder durch
 
File->New->Matlab Project
 
File->New->Matlab Project
oder durch das Kontextmenü
+
oder durch
  +
Kontextmenü (rechter Mausklick) im Matlab Projects View > New > Matlab Project
   
  +
Bitte gebt diesem Projekt den Namen: Uebung 1
==== Unmittelbares Feedback über den Lernerfolg ====
 
  +
  +
==== Erstellen eines Matlab Files ====
  +
  +
In diesem Matlab Projekt könnt ihr nun ein neues Matlab File erstellen.
  +
  +
Entweder:
  +
File->New->Matlab File->Oben Auswahl auf Uebung 1 setzen->File name: basis1.m
  +
oder das gleiche wieder über das Kontextmenü im Matlab Projects View
   
 
==== Unterstüzung der StudentInnen bei der Lösung der Beispiele (elektronischer Tutor) ====
 
==== Unterstüzung der StudentInnen bei der Lösung der Beispiele (elektronischer Tutor) ====

Version vom 27. Februar 2006, 13:41 Uhr

Übungsblätter

Startet den Browser durch Klick auf das Desktopicon Firefox / Browser.

Die Übungsblätter findet ihr unter: http://itp.tugraz.at/wiki/index.php/Applikationssoftware_und_Programmierung

TIP: Im Firefox könnt ihr mehrere Tabs

MLTutor Bedienung

Starten des Programms

Startet das Programm durch Doppelklick auf das Matlab-Tutor Desktop Icon.

Nach dem Start seht ihr ein Login-Fenster, bei dem ihr euch mit dem Benutzernamen und Passwort, dass ihr auch zum Login in das System verwendet, anmeldet.

Wenn ihr euch das erste Mal anmeldet, werden einige persönliche Infos erfragt. Bitte tragt bei Namen nur euren Nachnamen ein. Das Vornamenfeld kommt noch..

Diese könnt ihr auch im Nachhinein immer ändern, indem ihr das entsprechende Toolbaricon im MLTutor auswählt (Bitte Tooltip beachten)

Ein erstes Projekt

Erstellt ein erstes Matlab Projekt entweder durch

 File->New->Matlab Project

oder durch

Kontextmenü (rechter Mausklick) im Matlab Projects View > New > Matlab Project

Bitte gebt diesem Projekt den Namen: Uebung 1

Erstellen eines Matlab Files

In diesem Matlab Projekt könnt ihr nun ein neues Matlab File erstellen.

Entweder:

File->New->Matlab File->Oben Auswahl auf Uebung 1 setzen->File name: basis1.m 

oder das gleiche wieder über das Kontextmenü im Matlab Projects View

Unterstüzung der StudentInnen bei der Lösung der Beispiele (elektronischer Tutor)

Plattformübergreifend (Linux, Windows, MacOSX)

Graphische Oberfläche (IDE)

Benutzung freier Software

Keine private Matlab Lizenz erforderlich

So wenig Einschränkungen wie möglich bei der Erstellung der Beispiele

Erweiterbarkeit auf beliebige interpretierte (z.B. Python, Ruby, Javascript, C-Interpreter) und vielleicht auch kompilierte Sprachen.