MLTutor: Unterschied zwischen den Versionen

Aus Physik
Zur Navigation springen Zur Suche springen
Zeile 32: Zeile 32:
 
In diesem Matlab Projekt könnt ihr nun ein neues Matlab File erstellen.
 
In diesem Matlab Projekt könnt ihr nun ein neues Matlab File erstellen.
 
Entweder:
 
Entweder:
File->New->Matlab File->Oben Auswahl auf Uebung 1 setzen->File name: basis1.m
+
File->New->Matlab File->Oben Auswahl auf Uebung_1 setzen->File name: basis1.m
 
oder das gleiche wieder über das Kontextmenü im "Matlab Projects View"
 
oder das gleiche wieder über das Kontextmenü im "Matlab Projects View"
   

Version vom 27. Februar 2006, 17:50 Uhr

Übungsblätter

Startet den Browser durch Klick auf das Desktopicon Firefox / Browser.

Die Übungsblätter findet ihr unter: http://itp.tugraz.at/wiki/index.php/Applikationssoftware_und_Programmierung

TIP: Im Firefox könnt ihr mehrere Tabs gleichzeitig öffnen: Rechtsklick auf Link -> Open Link in new Tab

MLTutor Bedienung

Starten des Programms

Startet das Programm durch Doppelklick auf das Matlab-Tutor Desktop Icon. Nach dem Start seht ihr ein Login-Fenster, bei dem ihr euch mit dem Benutzernamen und Passwort, dass ihr auch zum Login in das System verwendet, anmeldet. Wenn ihr euch das erste Mal anmeldet, werden einige persönliche Daten erfragt. Bitte tragt bei Namen nur euren Nachnamen ein. Das Vornamenfeld kommt noch..

Diese Daten könnt ihr auch im Nachhinein immer ändern, indem ihr das entsprechende Toolbaricon im MLTutor auswählt (Bitte Tooltip beachten)

Ein erstes Projekt

Erstellt ein erstes Matlab Projekt entweder durch

 File->New->Matlab Project

oder durch

Kontextmenü (rechter Mausklick) im Matlab Projects View > New > Matlab Project

Bitte gebt diesem Projekt den Namen: Uebung_1

Erstellen eines Matlab Files

In diesem Matlab Projekt könnt ihr nun ein neues Matlab File erstellen. Entweder:

File->New->Matlab File->Oben Auswahl auf Uebung_1 setzen->File name: basis1.m 

oder das gleiche wieder über das Kontextmenü im "Matlab Projects View"

Problem View

Wenn ihr ein Matlab File bearbeitet, wird jeweils nach dem Speichern eine Syntaxüberprüfung durchgeführt. Etwaige Probleme seht ihr rechts unten im "Problems View". Durch Klick auf das jeweilige Problem springt ihr zur Zeile, in der das Problem auftaucht.

Zeilennummern

Ihr könnt die Zeilennummern im Matlab Editor durch

Window->Preferences->Matlab Editor->Show Line Numbers

einschalten

Matlab Console

In der Matlab Konsole könnt ihr Matlab Befehle eingeben, die mit RETURN ausgeführt werden.

TIP: Durch Pfeil rauf und runter könnt ihr in der Command History vor und zurückblättern.

Matlab Workspace View

Ihr könnt die Variablen, die in eurem Workspace zur Verfügung stehen im Matlab Workspace View unterteilt in globale und lokale Variablen betrachten

Ausführen eines Matlab Skripts

Ein Matlab Skript könnt ihr entweder durch:

Kontextmenü (rechter Mausklick) auf Datei -> Run Matlab Skript

oder über das entsprechende Icon in der Toolbar ausführen.

TIP: Um das Ergebnis bzw. veränderte Variablen zu sehen wechselt bitte in den "Matlab Workspace View"