MLTutor Admin

Aus Physik
Wechseln zu: Navigation, Suche

Versionshistory

MLTutor_Aenderungen_19012008

Version für MAC OS X: /afs/itp.tugraz.at/proj/mml/MLTutor/macosx/mltutor_macosx_19012008.zip

(a) NEUE FEATURES:

Generell:

- WICHTIG: Commit und Run Matlab Example in der Matlab Workbench sind nicht mehr über example.mlt sondern über das Kontextmenü des Projekts zu erreichen.

- WICHTIG: Neues Eclipse Aussehen Für neue Studenten werden diese 3 Einstellungen automatisch gesetzt, für alle anderen nicht, da daweil ja nur ich das getestet habe: (1) In Window -> Preferences (MAC OS X: MLTutor->Einstellungen) -> General -> Appearance Current Presentation auf MLTutor Presentation setzen (2) OverridePresentationSettings anhackeln (3) ViewTabPositions auf Bottom stellen

Neue Eclipse Presentation, dh. die ganze Oberfläche schaut ähnlich aus wie Visual Studio. Meiner Meinung nach wirkt das besser. Die Tabs der Views sind jetzt unten. Zu den Farben: Basiert auf einem VS-Plugin für Eclipse http://andrei.gmxhome.de/skins/index.html. Dies sind die Standardeinstellungen wie es auch im VS aussieht. Wenn ihr diese ändert wollt könnt ihr das unter Window-> Preferences (MAC OS X: MLTutor->Einstellungen..) General -> Appearance -> Colors and Fonts -> MLTutor Presentation machen. Wenn euch ein besseres Farbschema gefällt, dann macht einfach ein File -> Export -> General -> Preferences -> Export All und schickt mir das File. Ich mache es dann zum Standard. Wenn ihr auf die alte Oberfläche zurückkehren wollt, macht ein Window->Preferences-> General->Appearance->Current presentation->Default

- Beim Directorywechsel entweder durch Klicken auf den violetten Knopf oben, oder durch auswählen eines Beispiels wird nun eine Ausgabe in der Konsole erzeugt, da es zumindest mich verwirrt hat, nicht zu sehen, ob es wirklich funktioniert hat.


Matlab Console:

- Matlab Console Font und Farben komplett frei einstellbar. Ihr findet die Einstellungen unter Window-> Preferences (MAC OS X: MLTutor->Einstellungen..) unter General->Appearance->Colors and Fonts->MLTutor Matlab Console. Voreingestellt ist nun ein größerer Font der dem Standardfont von Dialogen entspricht. Genauso hier: Falls ihr bessere Voreinstellungen habt, schickt sie mir durch Preferences-Export.

Versionen:

- Commit Statements werden nun im Versionsview angezeigt.

- Nach dem Commit eines Beispiels werden die Beispiele in der Matlab Tutor Ansicht sofort upgedated.

- Neue Beispiele können hinzugefügt werden, indem man einfach ein Commit MLTutor Example macht. Das Programm frägt dann nach, in welche Kategorie das Beispiel kommen soll.

- Nicht benötigte alte Versionen können nun gelöscht werden -> Rechts klicken -> Delete im Versionsview. wird jedoch nicht gleich upgedated, dh, ihr müsst auf ein anderes Projekt klicken und dann wieder auf das vorige, bei dem ihr die Version gelöscht habt, um die Änderung auch im Versionsview zu sehen. Dh. es ist leider noch nicht möglich mehrere Versionen nacheinander zu löschen (RSE Error) sondern ihr müsst löschen - wechseln - zurückwechseln - löschen

Skriptum:

LaTeX Projekte sollte man nun ganz normal auschecken können. Das heißt z.B. das Skriptum mit Rechtsklick auf Skriptum checkt alle 20 Kapitel aus. Das Einchecken ist noch nicht wirklich funktionsfähig, da ich die Anzeige der Versionen noch anpassen muss, aber die Bearbeitung funktioniert ohne Probleme.


(b) BEHOBENE BUGS:

Generell:

- neues mltutor_compare von Winny, die neuen Skalarvergleiche sollten funktionieren, bitte testen!

Versionen:

- Versionsanzeige funktioniert nun auch mit Beispielen, die " _" und andere Sonderzeichen im Projektnamen haben. Encoding-blabla..

- Versionsanzeige macht auch beim ersten Öffnen ein Update, falls ein MLTutor Projekt ausgewählt ist.

- PDF Files werden jetzt upgedated.

MLT Editor:

- Dependencies im XML-Editor werden wieder angezeigt

- MAC OS X: Refresh-Problem im Editor behoben

- Dirty status des Editors funktioniert, aber wird leider noch immer mit * in der Titelleiste angezeigt. Aber er fragt zumindest nicht mehr nach, wenn man nichts geändert hat.


Console:

- Matlab Directory wird bei Start auf Workspacelocation gewechselt

- MAC OS X: Directory Chooser funktioniert, $HOME ist nicht gesetzt, daher hat das Wechseln mit Tilde nicht funktioniert.

- MAC OS X: In der Konsole werden nun Errormeldungen auch angezeigt. Hat daran gelegen, dass Matlab diese unter MAC OS X anders als unter Linux auf stderr schreibt und nicht auf stdin.


(c) BEMERKUNGEN:

- Winny: Skriptum ist jetzt auf dem neuesten Stand

- MAC OS X Latex Einstellungen: MLTutor -> Einstellungen -> Texlipse -> Builder Settings -> Bin Directory of TeX Distribution -> Browse...

- External Tool Error beim Auschecken kann ignoriert werden - Kommt ab und zu. Da meldet sich der LaTeX Builder. Keine Ahnung, was er da macht.

(d) WAS NOCH KOMMT:

- Winny: Feld für Studentenphoto ist in die Datenbank und den Tomcat eingebaut. GUI gibt's aber noch keine, da ich mir noch überlegen muss, wo ich das Photo überhaupt einbaue (Tutor Ansicht).


- Reihenfolge der Beispiele, Beispielstatus (Vorübung, ...)

- Bearbeiten von Matlab Libraries

-Einchecken von LaTeX projekten

- MAC OS X: Plotproblem

Hab es mit dem neuen X11 noch nicht zum Laufen bekommen, aber dafür einmal ein Screenshot, wie es mit dem alten aussieht;-)

Mltutor plot mac.png


Nur was, was ich im Netz zum Fontproblem gefunden habe:



FONT SIZE PROBLEM UNTER LINUX:

von http://www.eclipse.org/swt/faq.php On GTK, how do I change the default fonts and colors of widgets? A: GTK uses a file called .gtkrc which is located in your home directory. On some versions of Linux, this file is called .gtkrc-2.0. Here is an example of the content of that file which sets the font and colors for Eclipse:

     style "eclipse" {
       font_name = "Sans 12"
       bg[NORMAL] = "#d6d3ce"
       bg[ACTIVE] = "#c7c2bc"
       bg[INSENSITIVE] = "#828282"
       bg[PRELIGHT] = "#3a6ea5"
       fg[NORMAL] = "#000000"
       fg[ACTIVE] = "#000000"
       fg[INSENSITIVE] = "#d4d0c8"
       fg[PRELIGHT] = "#ffffff"
     }
     class "GtkWidget" style "eclipse"
   

To turn off anti-aliasing of fonts you should use the facilities available in your desktop if possible, such as the Gnome Font Properties dialog. An alternate approach is to ensure that your ~/fonts.conf or system-wide fonts.conf file contains the following:

   <match target="font">
   <edit name="antialias" mode="assign"><bool>false</bool></edit>
   <edit name="hinting" mode="assign"><bool>true</bool></edit>
   <edit name="autohint" mode="assign"><bool>false</bool></edit>
   </match>

Wenn nix mehr geht

Sollte der Workspace eines Studenten/einer Studentin zerstört sein, bitte folgende Schritte ausführen:

  • MLTutor schließen
  • cd
  • cp .mltutor/workspace -r tempworkspace ... Kopiert den Workspace an einen anderen Ort
  • rm .mltutor/workspace -rf ... Löscht den Workspace
  • MLTutor neu starten - bekommt leeren Workspace
  • File -> Import .. -> General -> Existing Projects into Workspace
  • Bei Select Root Directory ~/tempworkspace auswählen
  • WICHTIG: Unten Copy Projects into Workspace auswählen, sonst erzeugt er nur einen Link an den Ort und die Projekte werden beim Entfernen des tempworkspace-directories gelöscht.
  • Alle Projekte auswählen
  • Finish

Bekannte Bugs

Fehler: Matlab Communication Error od. XML Error bei "Save and Run Script"

Tritt selten aufDa es ein Threadproblem mit dem gleichzeitigen Abspeichern und Ausführen gibt, den Studenten/die Studentin bitten, vorher zu speichern und dann erst auszuführen.