Meditor Benutzerseite

Aus Physik
Wechseln zu: Navigation, Suche

Seit 28.02.2006 arbeitet MLTutor mit der neuesten Version des Matlab-Editors. Genauere Informationen zu diesem gibt es unter Meditor.

Das Hauptaugenmerk lag bei der Entwicklung bisher auf den Gebieten Syntax-Highlighting, automatische Einrückung und kontextspezifische Hilfefunktionen.

Der Matlab Editor im MLTutor lebt! Er wächst, gedeiht und reift, macht aber sicher auch Fehler.
Aus diesem Grund möchte ich alle seine Benutzer bitten, alle Fehler, Unvollständigkeiten, seltsamen Verhaltensweisen und natürlich auch alle Erweiterungs- und Verbesserungsvorschläge hier zu nennen um ihn zu einem ausgereiften, erwachsenen Tool zu entwickeln. Danke!
--Osiris 18:12, 28 February 2006 (CET)

Was kann der Editor

Hier nur eine kurze Beschreibung der wichtigsten Eingenschaften, genaueres kann man auf Meditor nachlesen.

  • Syntax-Highlighting:
    Hervorgehoben werden Kommentare, Strings, Keywords, Matlab-Funktionen, Zahlen
  • Einrücken und Ausrücken
    • reagiert auf Keywords und Fortsetzungszeilen
    • nach dem Fertigtippen eines Keywords wird die aktuelle Zeile passend eingerückt
    • Beim Löschen und/oder Einfügen von Text werden die betroffenen Zeilen passend eingerückt
    • nach Enter fängt die neue Zeile mit einer passenden Einrückung an
    • Verhalten von Tab wie in Emacs
    • Mit dem Menübefehl "Edit->Correct Indentation" oder der Tastenkombination "Strg+I" kann ein markierter Bereich passend eingerückt werden
  • Hilfefunktionen
    • Über das Menü "Help->Matlab help" oder die Taste F1 kann Hilfe zu jenem Befehl, bei dem der Cursor gerade steht, angefordert werden. In diesem Fall wird ein Browserfenster mit einer entsprechenden Hilfeseite geöffnet.
  • Auszeichnungssprache und Exportfunktionen
    • In Kommentaren kann mit Wiki-ähnlicher Syntax Text eingefügt werden, welcher beim Export in HTML oder PDF schön formatiert wird (Überschriften, Formeln, ...).
    • Aktuelles File kann exportiert werden in: XML, LaTeX, HTML, PDF
    • Zwei Menüpunkte:
      • "File->Export as..." öffnet einen "Datei speichern" Dialog, wobei das Speicherformat aus der angegebenen Dateiendung erkannt wird
      • "File->Export" erstellt alle Ausgaben so wie in den Preferences definiert.
    • Genaueres siehe Meditor_XML-Export
  • Einstellbares: Für den Editor gibt es eine eigene Seite bei den Preferences, wo ein paar Sachen eingestellt werden können:
    • tabs oder spaces für die Einrückung verwenden
    • verwendete Farben
    • Preferences für den File-Export
      • Metadaten (Autor, Datum, ...)
      • Ausgabeformate
      • Ausgabeverzeichnis
  • Matching Brackets werden angezeigt

Fehler

Leider sind Eclipse & Java sooo betriebssystemunabhängig und tolerant, dass das Einspielen von Änderungen, gemacht im Eclipse3.2/SDK1.5/Debian zu Hause, in den MLTutor unter Eclipse3.2/SDK1.5/Debian am ITP vieeel zu einfach um zu funktionieren ist. Deshalb gibt es hier 2 Marker für Korrekturen:
Ausgebessert: Wurde im Code ausgebessert
Läuft im Computerraum: Die Änderung wurde in den MLTutor am Institut übernommen

Zeichenketten

- Zeichenkette in einer Zeichenkette wird nicht richtig als String erkannt, z.B.: str = '''string''' (Ergebnis: 'string') im Unterschied zu str = 'string' (Ergebnis: string) --Kernbich 11:37, 24 January 2006 (CET)

Ich hab jetzt (bei meiner Version mit erweiterter RegExRule) die verschiedensten Varianten durchprobiert. Ein normaler String schaut so aus: 'string', wenn ich etwas mit noch mehr String-Zeichen umschließe, egal ob mit " oder ', wird immer das Ganze als String eingefärbelt, z.B.: '"hollareeeduliöööh"'.
Übrigens hab ich ausprobiert was mich Matlab (die Version im ITP-Computerraum) stringisieren lässt, und da war die letzte Variante, jedoch mit beliebig vielen " zwischen den ', das Einzige was Matlab ohne Fehler geschluckt hat.
--Osiris 22:21, 25 January 2006 (CET)

Kontrollstrukturen

- Ende in der selben Zeile, z.B.: if nargin < 1, x=3; end --Kernbich 11:37, 24 January 2006 (CET)

Läuft im Computerraum
--Osiris 10:49, 27 January 2006 (CET)

Verhalten

- Will man markierten Text ersetzen, springt der Editor an eine komplett falsche Position wenn man zum Tippen anfängt. --Kernbich 11:37, 24 January 2006 (CET)

Läuft im Computerraum
--Osiris 10:49, 27 January 2006 (CET)

- Beim Löschen des ersten Zeichens einer Zeile springt der Cursor in die vorherige Zeile (gemeldet von Kernbich)

Der Fehler wurde erkannt und behoben: Ausgebessert
--Osiris 18:13, 28 February 2006 (CET)

Hilfe

- Zum : Operator wird keine Hilfe angezeigt.

Läuft im Computerraum
--Osiris 18:19, 28 February 2006 (CET)

Highlighting

Verbesserungsvorschläge